hanahanahunachi’s diary

Android studio でお勉強してます。

Plugin version (1.1.3-2) is not the same as library version (jre8-1.1.3-2)

build errorした。原因は多分、

Plugin version (1.1.3-2) is not the same as library version (jre8-1.1.3-2)

というerrorみたいだった。

https://developer.android.com/studio/preview/features/new-android-plugin-migration.html#variant_aware

これの

buildscript {
    repositories
{
       
...
       
// You need to add the following repository to download the
       
// new plugin.
        maven
{
          url
'https://maven.google.com'
       
}
   
}

    dependencies
{
        classpath
'com.android.tools.build:gradle:3.0.0-alpha1'
   
}
}

 加えたら治った。kotlin関係のバグなのか私がやばいことしたのか・・・?

初心者なのでわからない。

もしわかる方いたら教えてください。