hanahanahunachi’s diary

Android studio でお勉強してます。

一般人なら絶対に踏まないbugやerror[4]

Errorのlogは,必ずしも正しいわけではない.

 

それはそうですね.

今日のバグはこちら.

You need to use a Theme.AppCompat theme (or descendant) with this activity.

これに関してググる

You need to use a Theme.AppCompat theme (or descendant) with this activity. - Google 検索

 

まあ素晴らしいstack over flow, qiitaなどに書かれた解決法が見つかるのね.

 

私は,themeはAppCompatを継承しているのにしてたし,何でやろ...って思ったのね.

色々試してダメだったから結局怪しい所がないか探して,書き換えてたら解決したのね.原因は,dialog生成部分だったのね...(まじで関係ない)

ググってどうにかしようの前に,自分のコード見直してからにしような...(檄冷)